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Learning Objectives

After learning this chapter, the students will 
be able to 

•	 Know the OpenSource presentation 
software

•	 Explore opening a new presentation 
using Impress

•	 Create a new presentation using various 
ways using Impress

•	 Know parts of the main Impress 
W i n d o w

•	 Differentiate five sections of Task pane

•	 Explain Window elements of Impress 

•	 Differentiate various views in 
W o r k s p a c e

•	 Explore drawing Objects and inserting 
OLE

•	 Draw freeform shapes

•	 Rotate Objects

•	 Create animation in slides/objects

12.1 Presentation Software - 
Meaning

•	 A presentation software is a computer 
software package used to show 
information, in the form of a slide 
show. 

It includes three major functions: 

•	 an editor that allows the text to be 
inserted and formatted, 

•	 a method for inserting and 
manipulating graphic images.

•	 a slide-show system to display the 
content.

•	 Presentation software is used to create 
presentations, quizzes, e-learning 
packages and multimedia products.

•	 Most presentation software packages 
will create your multimedia product 
using a series of slides. 

•	 Text, images, video, animation effects, 
links and sound can be combined on 
each slide to create a final product.

	 The most commonly known 
presentation programs are OpenOffice 
Impress, Microsoft PowerPoint and 
Apple's Keynote. In this chapter, we 
are going to explore on OpenOffice 
presentation Software Impress.

Presentation Basics

CHAPTER 12Unit IV Presentation
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12.2. Impress 

	 Impress is the 
OpenOffice presentations 
(slide show) module. You can 
create slides using Impress. It 
contains different elements like 
text, bullets and numbered lists, 
tables, charts, clipart and a range 
of graphic objects. Impress has 
access to the spelling checker 
and thesaurus. Also, it comes 
with pre-packaged text styles, 
background styles with online 
help.

12.3. Opening a new 
presentation 

You can start Impress in several 
ways:

•	 In order to open Impress 
using Start button, click 
Start button and select All 
Programs → OpenOffice   
4.1.4 → OpenOffice 
Impress. (Figure 12.1)

•	 If it is already pinned in the 
Start menu, just click and 
open it. (Figure 12.2)

12.4. Creating a new 
presentation

You can create a presentation 
by any one of the following 
methods.

1.	 By selecting an Empty 
p r e s e n t a t i o n

2.	 By selecting From Template

Figure 12.1 – Opening Impress 
using Start → All Programs

Figure 12.2 – Opening Impress using Start button
	 3.  By selecting from Open existing 
presentation
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12.4.1. Using Empty presentation
1.	 Select Empty presentation under 

Type. It creates a presentation from 
scratch.

2.	 Click Next. The Presentation Wizard 
Step 2 appears. Figure 12.4 shows the 
Wizard. 

3.	 Choose a design under Select a slide 

design. The slide design section gives 
you two main choices: Presentation 
Backgrounds and Presentations. 

4.	 Select the output medium from the 
list of choices for slide design. Choose 
anyone from the list. The preview of 
the same will be shown in the preview 
pane. 

Figure 12.3 – Using the Presentation Wizard to choose the type of presentation

Figure 12.4 Wizard showing the main choices
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5.	 <Original> is an empty background. 
You can also select among three 
predefined Presentations: <Original>, 
Introducing a New Product, and 
Recommendation of a Strategy. 
(Figure 12.6).

6.	 Click an item to see a preview of the 
slide design in the Preview window.

7.	 Select how the presentation will be 
used under Select an output medium. 
Generally, presentations are created 
for computer screen display, so select 
Screen option. (Figure 12.6). 

8.	 Click Next. The Presentation Wizard 
Step 3 appears (Figure 12.7). In this 
step, you can choose the desired slide 
transition from the Effect drop-down 
menu. Select the desired speed for 
the transition between the different 
slides in the presentation from the 
Speed drop-down menu. Medium is 
a good choice. Click Create. A new 
presentation is created. (Figure 12.8)

Figure 12.5 Selecting a slide design using Presentation Backgrounds
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Figure 12.6 Selecting a slide design using Presentations

Figure 12.7 Selecting a slide transition effect
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12.4.2. Using Template
•	 If you choose the option From 

template, it uses a template design 
already created as the basis for a new 
presentation. The wizard changes 
to show a list of available templates. 

Choose the template that you want. 
(Figure 12.9).

•	 "Introducing a New Product" and 
"Recommendation of a Strategy are 
pre-packaged presentation templates. 

Figure 12.8 New presentation

Figure 12.9 Opening a new presentation using From template option
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12.4.3. Using Open existing presentation

•	 If you choose the option Open 
existing presentation, it helps in 
continuing the work on a previously 
created presentation. 

•	 You have to open a presentation 
already prepared by clicking Open 
button. The wizard changes to show 
a list of existing presentations, from 
which you can choose the one that 
you want. (Figure 12.10). 

Figure 12.10 Opening a new presentation using Open existing presentation option

Figure 12.11 Opening a new presentation using New icon
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First Spreadsheet
Tip Notes

•	 If you do not want the wizard 
to start every time you start 
Impress, select the Do not show 
this wizard again checkbox.

•	 Leave the Preview checkbox 
selected, so templates, slide 
designs, and slide transitions 
appear in the preview box as 
you choose them.

Various ways of Starting Impress:

You can start Impress in various methods.

1.	 You can select the presentation from 
the system menu or the OpenOffice 
Quickstarter.

2.	 Or you can click the New icon and 
select Presentation from the drop-
down menu (Figure 12.11).

3.	 Or else, choose File → New → 
Presentation. (Figure 12.12).

12.5. Parts of the Main Impress window

	 The main Impress window (Figure 
12.13) has three parts: the Slides 
pane, the Workspace and the Task 
pane. Additionally, several toolbars 
can be displayed or hidden during the 
creation of a presentation.

Tip Notes

You can remove the Slides pane or 
Tasks pane from view by clicking the 
Close (X) option in the upper right 
corner. You can also show or hide 
these panes using View→Slide Pane 
or View →Task Pane/Side bar.

	
Figure 12.12 Opening a new presentation using File menu
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Figure 12.13 Main window of Impress
12.5.1. Slides pane

•	 The Slides pane contains thumbnail 
pictures of the slides in your 
presentation, in the order of our 
insertion of slides. 

•	 Clicking a slide in this pane selects it 
and places it in the Workspace. While 
it is there, you can apply any changes 
that are desired to that particular 
slide.

	 Several additional operations can 
be performed on one or more slides in the 
Slides pane:

•	 Add new slides at any place within 
the presentation after the first slide.

•	 Mark a slide as hidden so that it will 
not be shown as part of the slide show.

•	 Delete a slide from the presentation if 
it is no longer needed.

•	 Rename a slide helps to change the 
name of a slide. The default names 
are  slide1,  slide2,....

•	 Copy or move the contents of one 
slide to another (copy and paste, or 
cut and paste, respectively).

	 It is also possible to perform the 
following operations, other than using the 
Slides pane.

•	 Change the slide transition following 
the selected slide or after each slide in 
a group of slides.

•	 Change the sequence of slides in the 
presentation.

•	 Change the slide design. (A window 
opens allowing you to load your own 
design.)

•	 Change slide layout for a group of 
slides simultaneously. (This requires 
using the Layouts section of the Tasks 
pane.)
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12.5.2. Tasks pane

The Tasks pane has five sections:

1. Master Pages

	 You can define the page style for 
your presentation using Master Pages. 
Impress contains pre-packaged Master 
Pages (slide masters). One of them by 
default is blank, and the rest have a 
specific background. (Figure 12.14)

Figure 12.14 Master Pages

2. Layout

	 Pre-packaged layouts are shown. 
You can choose the one that you want, 

use it as it is or modify it to suit your own 
requirements. At present, it is not possible 
to create custom layouts. (Figure 12.15)

Figure 12.15 Layout

3. Table Design

	 Standard table styles are provided 
in this pane. You can further modify the 
appearance of a table with the selections to 
show or hide specific rows and columns, 
or to apply a banded appearance to the 
rows and columns. (Figure 12.16)
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Figure 12.16 Table Design

Figure 12.17 Custom Animation

4. Custom Animation

	 A variety of animations for 
selected elements of a slide are listed 
here. Animation can be added to selected 
elements of a slide and it can also be 
changed or removed later. (Figure 12.17)

5. Slide Transition

	 Transitions are available, including 
No Transition. You can select the 
transition speed (slow, medium, fast). You 
can also choose between an automatic or 
manual transition, and how long you want 
the selected slide to be shown (automatic 
transition only). (Figure 12.18)

Figure 12.18 Slide Transition
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12.6. Window elements of Impress 

	 Figure 12.19 shows the elements 
of the Impress Window Open source 
appl ic at ion .

	 The window elements of Impress 
include Title Bar, Menu Bar, Tool Bar, 
Ruler Bar and the Scroll Bar which are 
similar to the elements in Open Office 
writer.

12.6.1. View Buttons: 

	 The Workspace has five tabs: 
Normal, Outline, Notes, Handout, and 
Slide Sorter, as seen in Figure 12.19. 
These five tabs are called View Buttons. 

12.6.2. Status Bar: 

	 Status Bar is present at the bottom 
of your window, which gives you some 
statistics about the file that you are 

viewing. It is a good practice to check 
the information shown there. In case 
you do not need the information in the 
Status Bar, you can hide it by selecting                          
View → Status Bar from the main menu.

12.6.3. Navigator

	 The Navigator (Figure 12.20) 
displays all objects contained in a 
document. It provides another convenient 
way to move around a document and find 
items in it. The Navigator button is located 
on the Standard toolbar. You can also 
display the Navigator by choosing Edit → 
Navigator on the menu bar or pressing 
Ctrl+Shift+F5 .

	 The Navigator is more useful if you 
give your objects (pictures, spreadsheets, 
and so on) meaningful names, instead of  
names as “Object 1” and “Picture 1” as 
shown in Figure 12.20.

Menu Bar

View Button

Tool Bar

Scroll Bar

Figure 12.19 Window elements of Impress
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Figure 12.20 Navigator

12.7. Workspace

	 The Workspace has five tabs: 
Normal, Outline, Notes, Handout and 
Slide Sorter, as seen in Figure 12.19. 
These five tabs are called View Buttons. 
There are many toolbars that can be used 
during the slide creation; they are revealed 
by selecting them with View → Toolbars.

	 The actual Workspace section is 
below the View Buttons. This is where 

you assemble the various parts of your 
selected slide. Each view is designed to 
ease the completion of certain tasks. 

Normal view is the main view for creating 
individual slides. Use this view to format 
and design slides and to add text, graphics 
and animation effects.

Outline view shows topic titles, bulleted 
lists and numbered lists for each slide in 
outline format. Use this view to rearrange 
the order of slides, edit titles and headings, 
rearrange the order of items in a list and 
add new slides.

Notes view lets you add notes to each slide 
that are not seen when the presentation is 
shown.

Slide Sorter view shows a thumbnail 
of each slide in order. Use this view to 
rearrange the order of slides, produce 
a timed slide show, or add transitions 
between selected slides.

Handout view lets you print your slides 
for a handout. You can choose one, two, 
three, four, or six slides per page from 
Tasks pane → Layouts. Thumbnails can 
be re-arranged in this view by dragging 
and dropping them.

12.7.1. Normal view

	 There are two ways to place a slide 
in the Slide Design area of the Normal 
view: clicking the slide thumbnail in the 
Slides pane or using the Navigator.

	 To open the Navigator, click the 
Navigator button  in the Standard Toolbar 
or press Ctrl+Shift+F5 and select a slide 
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by scrolling down the Navigator list until 
you find the one that you want and then 
double-click it. (Figure 12.21).

12.7.2. Outline view

	 Outline view contains all the slides 
of the presentation in their numbered 
sequence. Only the text in each slide is 
shown. Slide names are not included.

Outline view serves for two purposes.

1) Making changes in the text of a slide:

•	 Add or delete text in a slide just as in 
the Normal view.

•	 Move the paragraphs of text in the 
selected slide up or down by using the 
up and down arrow buttons (Move Up 

or Move Down) on the Text Formatting 
toolbar.

	 Change the outline level for any 
of the paragraphs in a slide using the left 
and right arrow buttons (Promote or 
D em ote ) . 

	 Both move a paragraph and change 
its outline level using a combination of  
four arrow buttons. 

2) Comparing the slides with your outline 
(if you have prepared one in advance). If 
you notice from your outline that another 
slide is needed, you can create it directly 
in the Outline view or you can return to 
the Normal view to create it, then return 
to review all the slides against your outline 
in the Outline view.

Figure 12.21 Presentation in Normal view
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If a slide is not in the correct sequence, 
you can move it to its proper place:

a)	 Click the slide icon of the slide that 
you wish to move, as indicated in 
Figure 12.22.

b)	 Drag and drop it where you want.

12.7.3. Notes view

Use the Notes view to add notes to a slide:

1) Click the Notes tab in the Workspace 
(Figure 12.23).

2) Select the slide to which you will add 
notes.

Figure 12.22 Presentation in  Outline view 

Figure 12.23 Presentation in Notes view
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•	 Double-click the slide in the Slide 
pane, or

•	 Double-click the slide’s name in the 
Navigator.

3) In the text box below the slide, click 
on the words Click to add notes and 
begin typing.

	 You can resize the notes text box 
using the green resizing handles and  
move it by placing the pointer on the 
border, then click and drag. To make 
changes in the text style, press the F11 
key to open the Styles and Formatting 
w ind ow.

12.7.4. Slide Sorter view

The Slide Sorter view contains all of the 
slide thumbnails (Figure 12.24).

Use this view to work with a group of 
slides or with only one slide.

	 Change the number of slides per 
row, if desired:

1) Check View → Toolbars → Slide View 
to show the Slide view toolbar (Figure 
12.24 ).

2) Adjust the number of slides (up to a 
maximum of 15).

3) After you have adjusted the 
number of slides per row, 
View → Toolbars → Slide.                                                                                                          
View will remove this toolbar from 
v i e w .

To move a slide in a presentation using the 
Slide Sorter: 

1) �Click the slide. A thick black border is 
drawn around it.

2) �Drag and drop it to the location you 
want.

•	 As you move the slide, a black vertical 
line appears to one side of the slide.

•	 Drag the slide until this black vertical 
line is located where you want the slide 
to be moved

To select a group of slides, use one of 
these methods:

•	 Use the Control (Ctrl) key: Click 
on the first slide and, while pressing 
Control, select the other desired 
slides.
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Figure 12.24 Presentation in Slide Sorter view

•	 Use the Shift key: Click on the first slide, and while pressing the Shift key, select the 
final slide in the group. This selects all of the other slides in between the first and the 
last.

•	 Use the cursor: Click on the first slide to be selected. Hold down the left mouse 
button.

•	 Drag the cursor to the last slide thumbnail.

	 A dashed outline of a rectangle forms as you drag the cursor through the slide 
thumbnails and a thick black border is drawn around the selected slides. Make sure 
that this rectangle includes all the slides you want to select. (Figure 12.25)

To move a group of slides:

1) Select the group of slides.

2) Drag and drop the group to their new location. The same vertical black line appears 
to show you where the group of slides will go. You can work with slides in the Slide Sorter 
view as in the Slide pane.

	 To make changes, right-click a slide and do the following, using the pop-up menu:
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•	 Add a new slide after the selected slide.

•	 Delete or rename the selected slide.

•	 Change the Slide Layout.

•	 Change the Slide Transition.

–	 For one slide, click the slide to select it. Then add the desired transition.

–	 For more than one slide, select the group of slides and add the desired transition.

•	 Mark a slide as hidden. Hidden slides will not be shown in the slide show.

•	 Copy or cut and paste a slide.

Figure 12.25 To move a slide in a presentation using the Slide Sorter

12.7.5. Handout view

	 Handout view is for setting up the layout of your slides for a printed handout. Click 
the Handout tab in the workspace, then choose Layout in the tasks pane (Figure 12.26). 
You can then choose to print one, two,three, four, or six slides per page.

To print a handout:

1)	 Select the slides using the Slide Sorter. (Use the steps listed in selecting a group of 
slides.)

2)	 Select File → Print or press Ctrl+P to open the Print dialog box.

3)	 Select Options in the bottom left corner of the Print dialog box.
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4)	 Check Handouts in the Contents section, and then click OK.

5)	 Click OK to close the Print dialog box.

Figure 12.26 Presentation in  Handout view

Tip Notes

	 If you do not know the names 
for the pre-packaged layouts, you 
can use the tooltip feature. Position 
the cursor on an icon in the Layout 
section (or on any toolbar icon) 
and its name will be displayed in 
a small rectangle. If the tooltips 
are not enabled, you can enable 
them. From the main menu, select 
Tools→Options → OpenOffice.
org → General→ Help and mark 
the Tips checkbox. If the Extended 
tips checkbox is also marked, 
you will get more detailed tooltip 
information, but the tooltip names 
themselves will not be provided.
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Activity

Student Activity

1.	 Open a presentation using 

•	 Empty presentation

•	 From Template

•	 Open Existing Presentation

2.	 Compare the difference on opening the presentation using the above three methods.

3.	 Open impress using different ways.

Teacher Activity

This entire chapter can be taught with the help of the following methodology.

1.	 Laboratory Activity – the teacher can make the entire class to go to the lab and can 
explain the concept using a projector in the lab.

2.	 Or else, the teacher can demonstrate the concept using a PC and a projector inside the 
classroom.

3.	 The teacher apart from this Open source software, can compare the elements of the 
windows and creating presentations in MS PowerPoint also.

Evaluation

Part I

Choose the correct Answer

1.	 A convenient way to move around a document.

	 A) Compass 	 B) Navigator		 C) Fill color		  D) Page border

2.	 Which is the shortcut key to view the slideshow?

	 A) F6 		  B) F9			   C) F5			   D) F10
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3.	 In Impress, which views shows thumbnail versions of all your slides arranged in 
horizontal rows.

	 A) Notes		 B) Outline		  C) Handout		  D) Slide Sorter

4.	 Identify the default view in Impress.

	 A) Normal	 B) Slide Sorter	 C) Handout		  D) Notes

5.	 Which menu contains the Slide Transition option? 

	 A) Slide Show	 B) View		  C) Tools		  D )Format

6.	 Identify the extension of the Impress presentation.

	 A) .odp		  B) .ppt		  C)  .odb		  D) .ood

7.	 In presentation tools, the entry effect as one slide replaces another slide in a slide 
show. Identify the option  that suits after reading the statement.

 	 A) Animation 				    B) Slide Transition

	 C) Custom animation			  D) Rehearse Timing

8.	 Vanya has made a presentation on “Global Warming”. She wants to progress her slide 
show automatically while speaks on the topic in the class.  Which features of Impress 
would she use?

	 A) Custom Animation			   B) Rehearse Timing

	 C) Slide Transition			   D) Either (a) or (b).

Part II

Answer to all the questions (2 Marks)

1.	 What is the difference between a slide and a slide show?

2.	 How many in-built  slide layouts does impress consist of?

3.	 What do you understand by a presentation?

4.	 Define a template in Impress.

5.	 What do you understand by the slide layout?
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Part III

Answer to all the questions (3 Marks)

1.	 How many types of views are provided by Impress to its users?

2.	 Who uses the presentation software and why?

3.	 Define the Slide Sorter view and its significance.

4.	 What is a Normal view? Explain.

5.	 How are transition effects helpful in creating an effective presentation in Impress?

Part IV

Answer to all the questions (5 Marks)

1.	 Valarmathi’s teacher asks her to create a presentation in OpenOffice Impress. As 
Valarmathi has never worked in Impress before, help her to perform the following 
tasks:

a.	 She wants that except for the first slide, all the slides should have the same design. 
For this, what does she need to do?

b.	 To easily communicate with her audience, she wants to provide them with a hard 
copy of the slides of the presentation. What should she create for it? 

c.	 She wants to insert some pictures and movie files in some slides. How can she do 
that?

d.	 Suggest her the view that would be the most suitable for showing the presentation 
to the audience.

e.	 To make her presentation more attractive, she wants to add some effects in it. How 
can she do it? Suggest.

2.	 Explain how a presentation can help a sales person to promote his/her products.

3.	 Sivabalan created a presentation to be shown at his school’s Annual Function. Just 
5 minutes before the presentation, he noticed that he has misspelt the name of the 
school, which is appearing in all the 30 slides of the presentation. How can he rectify 
this mistake in all the slides in one-shot?

4.	 List some advantages of using templates.
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