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Learning Objectives

After the completion of this lesson, students will be able to: 

 � know how to create a spreadsheet through the Libre Office software.
 � explore their creative thinking.
 � learn how to use the functions.
 � learn how to create charts.

  Introduction

Libre Office Calc is one of the packages of 
Libre Office. It is mainly developed for calculation. 
Each page in Calc is called as spreadsheet. 
A  spreadsheet consists of rows and columns. 
Libre Office Calc can be opened by following 
ways.

1. Click Start Button
2. Click Libre Office Calc 

 23.1  Spreadsheet

There are numerous applications possible 
using electronic spreadsheets. A few of the 
common applications are given below.

• Payment of bills
• Income tax calculations
• Invoices or bills
• Account Statements
• Inventory Control
• Cost-Benefits Analysis
• Financial Accounting
• Tender Evaluation
• Result analysis of students

23.1.1  Advantages of using 
Electronic spreadsheets

The electronic spreadsheet offers several 
advantages over the manual one. The following 
are some of the main advantages of electronic 
spreadsheets.

• Calculations are automated through 
the built-in mathematical, financial and 
statistical functions.

• Accurate results to any desired level of 
decimal points are possible.

• Worksheets can be quite big in size.
• Any part of the worksheet can be viewed or 

edited.
• Worksheet can be saved and retrieved later.
• Any part or whole of an existing worksheet 

can be merged with any existing or new 
work sheet.

• Any part or whole of the worksheet can be 
printed in a desired format.

• Worksheet data can be viewed in the form 
of graphs or charts.

• The worksheet information can be 
transferred to any database or word 
Processing software.

LIBRE OFFICE CALC23
U N I T
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277 Libre Office Calc

 23.2  Worksheet and Workbook

A worksheet is the area where you perform 
all the tasks. You can enter and edit data in 
a work sheet. Combination of one or more 
worksheet forms a workbook. Every workbook 
contains three worksheets by default. Sheet-1 is 
the active worksheet when you open the Libre 
Office Calc window for the first time.

Column
A column is a vertical line of boxes. 

The columns are labeled from A to Z and 
thereafter as AA, AB……….up to AMJ.

Row
A row is a horizontal line of boxes. These 

are labeled with numbers like 1,2,3….and so 
on. There are 1,048,575 rows in a worksheet.

Cell 
The intersection of a row and a column 

is known as cell. Each cell is identified by its 

address. The cell address is a combination 
of column letter and row number. The first 
active cell’s address will be A1. The name box 
displays the address of the active cell.

Active Cell
The highlighted cell on the worksheet is 

the active cell. You can enter your data only in 
an active cell.

You can easily make any cell active by 
using a mouse or a keyboard. If you want 
to make the cell C2 active, just click on the 
cell C2. You can also use arrow keys to select 
a cell.

Range of Cells
A group of cells is known as range of cells. 

It forms a rectangle or a square. For selecting 
a range of cells, press and hold the shift key 
and use the arrow key.

In the image given below the range of 
cells is starting from C6 and ending at C9. 
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This is represented as C6:C9. Here colon (:) is a 
range indicator. You can easily deselect cells by 
clicking anywhere on the worksheet.

23.2.1  Create a New workbook

By default, you always get a workbook 
(book1) when you open Libre Office Calc 
application. If you want to create a new 
workbook then follow the steps given 
below.

1.  On the File menu, click New. The New 
Workbook task page will appear.

2.  Click Blank Workbook on the New 
Workbook task page. The New Workbook 
will appear.

23.2.2  Enter Content in a Cell

Enter the following content in the Libre 
Office Calc sheet.

Sl. 
No Name Ta

m
il

En
gl

is
h

M
at

hs

Sc
ie

nc
e

So
ci

al

1 S. Amirtha 89 65 67 63 76

2 S. Abarish 67 45 65 56 86

3 M. Vignesh 65 54 65 65 87

4 S. Yazhini 65 56 87 67 87

You can modify content in Calc sheet 
by moving cursor to that particular cell. The 
information will be displayed in the formula 

bar. Click on the text in the formula bar and 
make changes. You can also modify the text 
by double clicking on the Cell.

23.2.3  Saving the Worksheet

To save the worksheet created, go to the 
File menu and select the Save or Save As option.

Type a file name and click on Save. For 
example, to save the students’ marks, type the 
name Marks in the File name box and click 
on the Save button. You can also click on the 
Save icon on the Standard toolbar.

23.2.4  Closing the worksheet

In order to close the worksheet, go to File 
menu and select the Close option.

23.2.5  Opening a Worksheet

To open a worksheet that has been saved, 
select the Open option from the file menu. A 
dialog box with a list of files will appear on the 
screen. Select the file that you want by clicking 
on it and then click on Open. You can also click 
the Open icon on the Standard toolbar to open 
an existing file.

23.2.6  Quitting from LibreOffice

The Exit Libre Office option under the 
File menu can be used to quit from Libre 
Office Calc.

 23.3  Merge cells

When you type text that is too long to fit 
in the cell, the text will overlap on the next 
cell. If you want it to display it in a single line, 
you can merge the cell.
1. Move to cell A1
2. Type Name list - VIII Std ‘A’
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3.  Go to format in the menu bar and choose 
merge cells. Or select the cells and press 
right click of the mouse button. Then 
select merge cells option.

 23.4  Generate Auto Numbers

Libre Office Calc allows you to generate 
auto numbers. To generate auto numbers, 
follow the steps given below.

1.  Enter first two numbers of the series in 
two cells.

2.  Select both the cells
3.  Move the cursor to the right-side bottom of 

the cell. The cursor will change to plus sign.
4.  Drag the plus sign to the cell you desire.
5.  The numbers will be generated 

automatically. You can generate any series 
by using this method.

 23.5  Functions

Functions can be used to perform simple 
or complex calculations.  You can use different 
formulae in Libre Office Calc. A formula in 
Libre Office Calc starts with an equal to (=) sign.

23.5.1  Text Formula

To create a simple text value, enclose 
it in double quotes.  The ampersand (&) 
character is used to join text values to one 
another.

For Example = “Libre” & “Office”

The result of this formula is ‘Libre Office’

23.5.2  Statistical Functions

In Libre Office Calc, there are many 
predefined formulae that can perform specific 
calculations. Some of them are given in the 
worksheet. 
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 23.6   Operators in Libre Office 
Calc

Operators in Libre Office Calc

Some of the operators in Libre Office Cal 
care: Arithmetic, Relational and Logical.

23.6.1  Arithmetic Operators
Arithmetic operators are used to do some 

kind of calculations with numeric values. 
They cannot be used with strings.

Operator Function Usage
+ Addition =20+10
- Subtraction =20-3
* Multiplication = 30*2
/ Division =100/4
^ Exponentiation =5^2
% Percent = 10%

23.6.2  Relational Operators
Relational operators are used to compare 

two values. They form relational expressions. 
These operators always give a single value as 
result: True or False

23.6.3  Logical Operators
Logical Operators are used to compare 

two or more relational expressions. These 
operators also always give a single value as 
result True or False.

Operator: NOT, AND, OR

Example 

Akshay’s mother has purchased some 
fruits from the market. Make a list of fruits 
and find how much each fruit costs her.

1. Make the initial worksheet

2. Type the formula = C3* D3in Cell E3.

3.  Similarly, type all the formulae in the 
other cells as given

4.  To calculate the grand total, Type the 
formula = E3 + E4+E5 +E6 in Cell E7 and 
press the enter key to get the result. Or 
Type the formula =sum (E3:E6) in Cell E7 
and press the enter key to get the result.

5.  Save the file with the name ‘Market’.

Function Description Example Result

SUM () Calculates the total of a given set of values = SUM(A2:A6) 335
AVERAGE () Calculates the average of given set of values = AVERAGE(A2:A6) 67
MAX() Calculates the maximum value from a 

given set of values
= MAX(A2:A6) 87

MIN () Calculates the minimum value from a 
given set of values

= MIN(A2:A6) 47

COUNT() Counts the number of values  
(cell containing numbers) 

= COUNT(A2:A6) 5

Operator Function Usage
= Equal to A1 = B2

<> Not Equal to C1 <> D1
> Greater than B2 > 50
< Less than C5 < 100

>= Greater than or equal to A1 >= B2
<= Less than or equal to E5 <= 5
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 23.7  Sorting Data

Arranging a given set of data according to 
a particular order (ascending or descending) 
is called sorting.

• Select the data which you want to  
Sort

• Click on Data → Sort 

 23.8  Working with Charts

One of the most popular features of Libre 
Office Calc software is to generate charts based 
on numeric data. The purpose of chart is to 
visualize the data for easy understanding. To 
draw a chart, follow the procedure given below:
•  Select the data which you want to chart.
•  Click on Insert → Chart or click on the 

Insert Chart icon.

 I. Choose the best answer.

1. All functions begins with an  ______ sign
a) =   b) -   c) >  d) }

2.  ______ function is used to calculate the 
total of a given set of values.

a) Average  b) Sum  c) Min  d) Max

3.  The _____ character is used in text formula.
a) Ampersand b) Comma
c) Exclamation d) Hyperlink

4. Which of the following is a relational 
operator?

a) +   b) >   c) -   d) NOT

5. The ________ function returns the 
smallest value in a set of values.

a) Average  b) Sum  c) Min  d) Max

II.  Answer in detail.

1.  Explain count function with an example.
2. What is the purpose of charts?
3. What is the use of Sorting?
4.   What is the use of MAX () and MIN () 

functions?
5. What is cell address?

 TEXTBOOK EXERCISES
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 GLOSSARY

அமிலம்	 - Acid 
அமிலமழை	 - Acid rain
வளர்	இளம்	பருவம்	 - Adolescence
காடுவளர்ப்பு	 - Afforestation
வவளாணழம	 - Agriculture 
உைவியல்	 - Agronomy 
உணவுப்	பாழை		 - Alimentary canal 
வீச்சு	 - Amplitude 
வேர்மினவாய்	 - Anode
அமிலநீக்கி	 - Antacid 
செயறழக	நிறஙகாட்டி	 - Artificial Indicator 
செயறழக	சுவாெம்	 - Artificial respiration
விணசவளி	வீரர்	 - Astronaut
மினகடதைாப்	சபாருள்	 - Bad conductor    
ெரிவிகிை	உணவு	 - Balanced diet
காரம்	 - Base
உயிரி	டீெல்	 - Bio Diesel 
உயிர்உரம்	 - Bio fertilizer 
உயிரி	பூச்சிக்சகால்லி	 - Bio pesticide 
உயிரி	சகானறுணணிகள்	 - Bio pradators
உயிர்க்வகாளம்	 - Biosphere
சகாதிநிழல	 - Boiling point 
எலும்பு	மஜ்ழஜ		 - Bone marrow
ைாவரவியல்	பூஙகா	 - Botanical garden 
குருதசைலும்பு	 - Cartilages
எதிர்மினவாய்	 - Cathode
மினதுகள்	 - Charge
வவதிச்ெமனபாடு	 - Chemical equation
வவதிவாய்பாடு	 - Chemical formula
நுண	வகெஙகள்		 - Cilia
அழுதைப்பட்ட	இயறழகவாயு	 - CNG
நிலக்கரி	வாயு	 - Coal gas 
கவலாரிமானி	 - Colorimeter
இறுக்கஙகள்	 - Compressions
ஒடுக்குைல்	 - Condensation
கடததுைல்	 - Conduction
பாதுகாப்பு	 - Conservation 
சவப்பச்ெலனம்	 - Convection
பள்ளஙகள்	 - Craters
பயிர்ப்	சபருக்கம்	 - Crop production 
எரிைல்	 - Cumbustion
வழளவான	அழமப்பு	 - Curved pattern 

காடு	அழிப்பு	 - Deforestation 
அடர்ததி	 - Density 
படிைல்	 - Deposition
பரிமாணஙகள்	 - Dimensions 
மினனிறக்கக்குைாய்	 - Discharge tube
புவிதசைாடுப்பு	 - Earthing 
மினபுலம்	 - Electric field
மினனழுதைம்	 - Electric potential
மினனிறக்கம்	 - Electrical discharge 
மினனாறபகுதைல்	 - Electrolysis 
மினமுலாம்	பூசுைல்	 - Electroplating 
ஆபதைான	இனஙகள்	 - Endangered species 
ோளமில்லா	சுரப்பிகள்	 - Endocrine glands
உள்	எலும்புக்கூடு		 - Endoskeleton
உரம்	 - Fertilizer
கழெயிழை	 - Flagellum
இழலயில்	சைளிப்பு	 - Foliar spray 
உழறநிழல	 - Freezing point 
உராய்வு	 - Friction
எரிசபாருள்	 - Fuel
மினஉருகு	இழை	 - Fuse
விணமீனதிரள்	 - Galaxy 
புவி	வடமுழன	 - Geographic north 
புவியியல்	 - Geological 
புவி	சவப்பமயமாைல்	 - Global warming
உலக	சவப்பமயமாைல்	 - Global warming 
ேறகடததி	 - Good conductor
பசுழம	இல்ல	விழளவு	 - Green house effect
கடின	நீர்	 - Hard water 
பாரம்பரியவிழை	 - Heirloom seed 
கிழடமட்டம்	 - Horizontal 
பிளக்க	முடியாை	 - Indestructible
நிறஙகாட்டி	 - Indicator 
தூணடல்	 - Induction 
குறசறாலி	 - Infrasonic 
உட்சகாள்ள	 - Ingeste
கனிம	அமிலம்	 - Inorganic acid 
இரும்புத	ைாதுக்கள்	 - Iron ores 
நீர்ப்	பாெனம்	 - Irrigation 
குரல்	வழள	 - Larynx
உள்ளுழற	சவப்பம்	 - Latent heat 
சுணணாம்பு	நீர்	 - Lime water
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சேட்டழல	 - longitudinal wave 
காநைப்புலம்	 - Magnetic field
காநைப்புலம்	 - Magnetic Field 
காநைததிறன	 - Magnetic power 
உரமிடுைல்	 - Manuring 
எநதிரவியல்	 - Mechanical wave 
மாைவிழடவு	 - Menopause
மாைவிடாய்	 - Menstruation
உவலாகஙகள்	 - Metals 
கணிமவியல்	 - Mineralogy 
வைசியபூஙகா	 - National park 
இயறழகவாயு	 - Natural gas
இயறழக	நிறஙகாட்டி	 - Natural Indicator 
ேடுநிழலயாக்கல்	 - Neutralisation
கரிமஅமிலம்	 - Organic Acid 
அழலவுறுைல்	 - Oscillate 
எலும்பு	சமனழமயாைல்	 - Osteoporosis
அணடம்	விடுபடுைல்	 - Ovulation
உழுைல்	 - Ploughing 
குடிப்பைறகு	உகநைநீர்	 - Potable water 
கர்ப்பமழடைல்	 - Pregnancy
எரிசபாருள்	 - Propellant 
உநதுவிழெ	 - Propulsion 
பருவமழடைல்	 - Puberty
சவப்பக்கதிர்வீச்சு	 - Radiation
ைளர்ச்சிகள்	 - Rarefactions 
சிவப்பு	ைரவுப்	புதைகம்	 - Red Data Book 
சுததிகரிப்பு	 - Refining 
குளிர்ொைனப்சபட்டி	 - Refrigerator

மினைழட	 - Resistance  
உவர்	நீர்	 - Saline water 
இரணடாம்நிழல		 - Secondary sex
	 பால்	பணபுகள்    characters
துணடு	 - Segment
எலும்புக்	கூடு		 - Skeleton
கபாலம்		 - Skull
வைவைப்புதைனழம	 - Soapy touch 
சூரிய	ஆறறல்	 - Solar energy 
புளிப்புச்சுழவ	 - Sour Taste
விழைதைல்	 - Sowing 
விணசவளி	ஆய்வுக்கலம்	 - Space probe 
ைனசவப்பம்	 - Specific heat 
ைன	சவப்ப	ஏறபுததிறன	 - Specific heat capacity
பைஙகமாைல்	 - Sublimation
சைாஙகவிடப்பட்ட	 - Suspended
மீசயாலி	 - Ultrasonic 
மாறறஇயலாை	 - Unaltered
அணடம்	(ம)	வபரணடம்	 - Universe 
சவறறிடக்குடுழவ	 - Vacuum flask
மாறும்	இழணதிறன	 - Variable valency
செஙகுதது	 - Vertical 
அதிர்வுகள்	 - Vibrations 
உள்ளுறுப்பு	 - Visceral organ
நீர்வாயு	 - Water gas 
அழலநீளம்	 - Wave Length 
கழள	 - Weed
வனஉயிரி	 - Wildlife 
காறறாறறல்	 - Wind energy
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